Godot isn't importing all animation frames?

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By Dumuz

I have an animation via .fbx that Godot is importing just fine except for one problem: It’s not importing every other frame.

I have pieces of the animation that change every frame and can see that they’re just missing in the animationplayer and on play back. When I check the .fbx file in blender, it has baked keyframes every frame.

So, the disconnect seems to be how Godot is importing the animation. Is there a way to control the keyframes being imported?

Support for animated FBX scenes in Godot is considered experimental, as the format is supported thanks to reverse engineering. Try using glTF 2.0 instead.

Calinou | 2020-03-31 07:07

Thanks for trying to help Calinou, I tried the gITF format and everything imports just fine, but with the same issue: It only imports every 7 frames worth of baked animation (I thought it was every other frame, but there’s more missing than that). The animation doesn’t look terrible, but there are some wiggling animations that update every frame. So where the wiggling happens 11 times in blender, it only happens roughly 3 times in Godot.

Is there an import setting for Godot’s animations to take in the entirety of the baked animations?

Dumuz | 2020-04-01 18:45