Godot One Click Deploy not working specifically on my phone after exporting a release version of the game. Any ideas?

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By macabilo

For a while now, I’ve been testing an Android custom build game with my Samsung Note 9 phone (with debug keystore). I generated a release keystore and exported a release version of the game which was successfully uploaded to Google Play. Everything went well as a set of internal testers were able to access the game flawlessly.

Since it was my first, I hastily uploaded a new release (one day after) to include few minor changes in the game. However, my phone didn’t install the new version, neither did the testers. Afraid that I might have done something wrong, I uninstalled the game and went back to Godot to do a debug build (one-click deploy). However, this didn’t work either. Since then, I cannot debug the game using my phone (debugging using the PC still works tho and the game works flawlessly there). I tried using another Android phone and the debug still works. So I thought that maybe the problem is with my phone.

I consulted forums that talked about wrong uninstalls, clearing Google Play cache, adb tools to check installation remnants, etc but the game is not in my phone anymore. It feels like a phantom copy of the game is preventing me from reinstalling the debug version of the game (idk). From this, you might already guess I’m a newbie and I appreciate if you can dumb it down for me >.<

I feel like I did a rookie mistake with the Android custom build exports in Godot and I cannot figure out what it did to my phone. Since there are no forum questions that are similar to my situation, I thought that this must be a simple mistake. Any ideas?

Does it work if you enable Clear Previous Install in the Android export preset? (Note that in 4.0, this option has been moved to the Editor Settings.)

Calinou | 2021-10-11 15:47

Thanks for the reply. Well, I tried to enable the clear previous install but what happened is the build process froze. I tried repeating it, and after waiting for about 20 mins or so, the app was not installed.

macabilo | 2021-10-17 13:51

:bust_in_silhouette: Reply From: macabilo

I finally found the solution. Previously, whenever I install a release version, a copy of the same game is installed in work profile and in the secret folder (Samsung Knox). After I deleted these copies, everything worked well.