Godot reverting to 60hz on 165hz monitor

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By sp3nt

I recently upgraded to a 165hz monitor and I have noticed that godot seems to run like its a 60hz app. For example when transitioning from the desktop (which is set to 165hz in my control panel) to the godot IDE app the mouse refresh rate slows down and causes my monitor to slightly flash different brightness’s.

I couldn’t find a setting in the editor settings or any threads about it on here.

I’ve tried increasing godots priority in windows but that doesn’t seem to change anything.

Any help would be greatly appreciated.


Did you tried to disable vsync in Project settings/Display/Window/Use vsync? Also check that Project settings/Debug/Settings/Force FPS set to 0.

AlexTheRegent | 2021-01-03 23:10

No improvements unfortunately

sp3nt | 2021-01-05 19:11

I have noticed that it only slows down while the mouse is other docked elements. It seems to be smooth when moving around a 2d/3d scene.

sp3nt | 2021-01-05 19:14

My bad, I though you have problem when running game, not in Editor. Did you tried looking for similar problems in godot’s github issues?

AlexTheRegent | 2021-01-07 13:45