Godot v3.1 Beta 3 Dynamic Font Anti-aliasing Help

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By JayH


I’m having an issue with Dynamic Fonts in Godot. I was using Stable v3.06, but found that you can’t switch off the Anti-aliasing on fonts, not great for a low resolution pixel style game!

In the Godot forum suggested I try the new Beta (v.3.1 Beta 3). Yep, there is an option for disabling Anti-aliasing which works on the editor/stage, but for some reason it doesn’t appear to work in the game window.

‘What to do?’ said Pooh.

Any ideas? is it intentional, or perhaps a bug?

Edit: Seems to happen to some fonts and not others. I was told that it is to do with OpenGL rendering and that I should use Pixel Snap, didn’t help though. For me changing to a font that worked was the solution.

:bust_in_silhouette: Reply From: rot18

It looks like bug, but I found workaround: create DynamicFontData in inspector and save on disc.