Godot v3.3.1.stable.official - Output stops working after installing apk to device (Android)

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By jackthedeeper

Greetings everyone,

I am facing this problem and I really don’t know what else should I do.
I found some relatable questions but no answers were satisfactory.

When I press the android icon on the upper right side, it installs and runs the APK on my phone with no problems.
But after that, I don’t get any other output.
If I run it locally on my PC, the output works just fine.
Basically, in my code I have a print and it only works when I run the code on PC, but not on android.

Thank you in advance!

Here is the output:

0 param: --remote-debug
1 param: localhost:6007
2 param: --xr_mode_regular
3 param: --use_depth_32
4 param: --use_immersive

A lot of *ADDING: … *

Installing to device (please wait…): Xiaomi Redmi Note 7
— Device API >= 21; debugging over USB —
Reverse result: 0

Some things you might need to know:

  1. Deploy with Remote Debug is checked

  2. Disable Stdout is unchecked

  3. Remote Host is

  4. Remote Port is 6007

  5. In cmd: adb devices -l:
    List of devices attached
    fde1044 device product:lavender model:Redmi_Note_7 device:lavender transport_id:5

  6. In cmd, adb version:
    Android Debug Bridge version 1.0.41
    Version 31.0.2-7242960

  7. In cmd, adb shell getprop ro.build.version.sdk:

  8. Google USB Driver is installed manually via Device Manager

  9. On my phone, USB Debugging is enabled

:bust_in_silhouette: Reply From: Maz90

Same thing just happened to me. I suspect the Timer nodes in my main scene are responsible for it.