Hard to track where error "get_relative_transform_to_parent: Condition "!parent_2d" is true. " comes from

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By CoreFlux

I’m transferring my project to Godot 3.5 stable, coming from 3.4 stable, and adapting to the new navigationserver. I think I’ve got most of it sorted out (thanks to a handy video by bitbrain), but I still get these red (but apparently not game breaking) errors in my log. Problem is, I don’t get a source in my script where they’re coming from, only the C++ source stack trace:

E 0:00:01.099 get_relative_transform_to_parent: Condition “!parent_2d” is true. Returned: Transform2D()
<C++ Source> scene/2d/node_2d.cpp:356 @ get_relative_transform_to_parent()

Since I’ve done a lot of adjustments for the new Navigation, it’s really hard to find out from what change this is coming from, so I was hoping someone else has had this error and can offer a “have you tried checking X yet?”.

:bust_in_silhouette: Reply From: CoreFlux

Apparently related to a bug with TileMap and the new Navigation system, set to be fixed in 3.6: `Condition "!parent_2d" is true.` error for `TileMap` with `bake_navigation=true` and no `Navigation2D` parent · Issue #64011 · godotengine/godot · GitHub . The fact I get it several times threw me off, because I have several Tilemaps, but only one that’s baking navigation.