Hide Console not working on Windows 11 in 3.4.2?

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By rakkarage

I have tried toggle in Editor->Editor Settings->Hide Console Windiw and Editor->Togfle System Console and both don’t work? I remember it used to work somehow but not sure if it broke or I am doing something wrong?


:bust_in_silhouette: Reply From: Calinou

Console handling has changed since 3.4.1 to work around an issue with Godot not starting on Windows 11 unless it was run from a command prompt: [Windows, 3.x] Open a new console window for the editor instances. by bruvzg · Pull Request #55925 · godotengine/godot · GitHub

A side effect is that hiding the console is no longer possible if you’re using the new Windows Terminal: [Windows, 3.x] Detect new Windows Terminal and disable unsupported set_console_visible code. by bruvzg · Pull Request #55967 · godotengine/godot · GitHub

As a workaround, you can change your system settings to use conhost.exe by default instead of Windows Terminal.