How do I disable shadows, keeping light occlusion at the same time?

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By godutmaster

This is my scene, its a simple Tilemap with Light2D.

As you can see, it casts shadows. I don’t like them however, so I’m gonna turn them off in my Light2D options.

Ok, the shadows are gone, but now all the walls are illuminated. I don’t want that, i just want the shadows on the floor to be gone.
How do i achieve that? This is my desired effect, made by combining the two previous pictures in my GNU GIMP program.
Maybe I should use some other node rather than Light2D?

Is the brown portion always darker? so why don’t you just make it darker in the sprite?
If for some reason you dont wanna do that, asuming you are using a tilemap, you could put the brown portion in a sepparate tileamp, and change the light layer so its just not affected by the light.

p7f | 2020-07-05 13:46

Im looking for an option that’d not require me to make another tilemap for my walls, I would have to rewrite the scripts i already wrote for this single node tilemap.

godutmaster | 2020-07-05 14:50