How do I disable the sky reflection on a material?

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By lqdev

Hello. I am trying to make a non-reflective material for my game. However, a sky reflection is visible just like on the screenshot below:

Sky reflection on my mesh

I am using ImmediateGeometry in order to generate a mesh, and it works well (there is no reflection), until I apply a material to it. Then the sky starts being visible in the material, which is unwanted behavior. How do I disable this reflection? I tried disabling Specular on the material with no luck.

I have searched the documentation but I can’t find the necessary information.

:bust_in_silhouette: Reply From: Calinou

As Godot 3 uses physically-based rendering, the Specular property only plays a minor part in a material’s reflectiveness. In addition to setting Specular to 0, you’ll want to set the Roughness value to 1 and Metallic to 0.

See Spatial Material in the documentation for more information about materials in Godot.

Thank you! For some reason I didn’t think of changing the roughness.

lqdev | 2018-08-01 18:15