How do I fix error: "No export template found at the expected path: [path]"?

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By kingzonas

I’m trying to debug on my phone, and I run into this error:

editor/export/editor_export_platform.h:173 - Run: No export template found at the expected path:
No export template found at the expected path:

I’ve tried installing the export template to that location, but judging by the fact that I still get the error, I assume I’m doing something wrong.

:bust_in_silhouette: Reply From: ibrahim.semab

It looks like the Godot Editor is not able to find the Android export templates at the expected location. Here are a few steps you can take to try to resolve this issue:

  1. Make sure you have installed the Android export templates for Godot
    4.0. You can download them from the official Godot website: Download - Godot Engine. Make sure you select the correct
    version for your operating system and architecture.

  2. Check the location where you installed the export templates. The
    default location for Windows is
    %APPDATA%\Godot\export_templates\4.0.stable.mono. Make sure that the
    Android export templates are located in this directory.

  3. Make sure that the file names for the export templates are
    androiddebug.apk and androidrelease.apk. If the file names are
    different, rename them to match the expected file names.

  4. If you have recently installed the export templates, try restarting
    the Godot Editor to see if the error goes away.

  5. If you still can’t resolve the issue, try resetting your Godot
    Editor settings to the default settings. To do this, go to Editor >
    Editor Settings, click the “Reset to Defaults” button, and then
    restart the editor.

Hopefully, one of these steps will help you resolve the issue and allow you to debug your project on your phone.

Hello! I also have an error, I can’t find a solution (

editor/export/editorexportplatform.h:173 - Export: Android project build failed, check output for errors

Dmitriy154 | 2023-05-13 10:30

Hey! I solved the issue by reinstalling the openJDK 11.

sudo apt-get remove openjdk*

sudo apt-get clean

sudo apt-get install openjdk-11-jdk

The cause of the problem in my case was jlink didn’t exists, but there was no error message for it. Let me know if it works for you.

Got help from this thread:
java - Could not resolve all files for configuration ':app:androidJdkImage - Stack Overflow

Jwheel | 2023-06-29 00:16