How do I fix this export issue: " Loaded resource as image file, this will not work on export..."

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By paulgguitar

Hi all,

Apologies in advance if there is a simple solution that I’ve missed. I’m trying to export the “Dodge the Creeps” game to Windows and to HTML5, but cannot get the file to run on either platform. I’m able to get it to run in the engine. When I export it to windows, I get an .exe file but all it does it make the godot icon flash in the taskbar towards the bottom of my screen. I got this error from the console:

Loaded resource as image file, this will not work on export: ‘res://icon.png’. Instead, import the image file as an Image resource and load it normally as a resource.

Please note, I’ve downloaded the templates and I’ve made sure that I’m putting the .exe and .pck files in their own separate file by themselves.

While there were few answers that worked for others on this forum/github/reddit, I’ve had a hard time understanding them (something about turning the .png into a resource?).

Can someone outline to me, as simply as possible, what to do to get the game to export so I can play it on windows/html5? Happy to provide screenshots; just didn’t know which ones would be relevant.


Try to reset the Icon field on Project Settings → General and them assing the icon again.

gold_monkey | 2020-04-21 19:51

:bust_in_silhouette: Reply From: adxsoft

I have exactly the same problem export to Mac :frowning:

I think you can’t just use icon.png but need an actual icon file on Mac its .icns not sure on Windows.

:bust_in_silhouette: Reply From: CharlesMerriam

The most common cause is the project including icon.png as a default setting. For running on the web, you should convert this to icon.icns. You can use this free converter page to do that.

Once you have the converted icon, go to Project/Project Settings/Application/Config/icons and select your new icon.icns. This doc page may help.

:bust_in_silhouette: Reply From: Surge

I’ve had the exact same problem before, only with shader palettes.

What I did was reimport the image as an image instead of a texture. You’d click on the image in the File Manager, then go to the Import tab and click the dropdown where "texture"s selected. Then change that to “Image” and click reimport. Should export without that issue.