How do I get rid of screen-door artifacts in reflection (Godot 3.0)?

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By garyo

I’m new to Godot, but really liking it. I’ve made a test scene, but I’m getting some screen-door artifacts in my reflections, as seen at -see the reflection of the bottom cube face in the floor. This speckling is even worse in motion, as you’d expect.

Both the plane and cube are using SpatialMaterial with a bit of metallic and roughness. I have one directional light and a reflection probe around the scene, and that’s about it.

Any ideas about how I should fix that?

image isn’t showing man, or is it just the “test image” text?

rustyStriker | 2018-02-07 21:19

Seems like the image didn’t link. Can you see this: ?

garyo | 2018-02-07 21:42

:bust_in_silhouette: Reply From: kkmzero

Hello, I know this is old issue but I had similar problem just now. The solution is simple: If this problem is not related to shadow bias, then it’s related to SS Reflections. Go to your environment settings, SS Reflections settings and change the Depth Tolerance (increasing it helped me). I hope this might help anybody with similar issue.