How do I get rid of the FOV scroll?

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By shweep

So I use the Maya Navigation Scheme, and Alt for the Pan modifier. Don’t think this makes a difference but it drives me insane that holding down alt and using the mouse scroll changes the editor camera fov.

Either I’m trying to pan or merely zooming and 50% of the time I’m messing up the fov and having to reset it. There seems to be nothing in the controls or any setting that can change or turn this off? Was this a recent update?

:bust_in_silhouette: Reply From: Calinou

This was added in 3.5 by The modifier is hardcoded, so it unfortunately can’t be disabled. I didn’t test navigation schemes other than Godot at the time, so I couldn’t spot this usability regression.

Edit: I opened a pull request to remove this shortcut: Remove FOV adjustment with Alt + mouse wheel in the 3D editor by Calinou · Pull Request #64070 · godotengine/godot · GitHub