How do I get the Android icon to appear at the top right of the editor?

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By JorensM

I set up all the necessary stuff for exporting for android, and it exports fine, but I was wondering how I can access the Android icon in the top right corner for faster debugging? It’s not showing up for me. I have USB debugging enabled on my device.

:bust_in_silhouette: Reply From: Wakatta

For Windows unsure you have your Android drivers installed

For Linux you may have to setup udev rules for your device

For Mac on some Android devices you also need to allow the pc connection (Android side)

When you are able to do adb devices in a terminal and your device registers then Godot will be able to debug it

I ran the “adb devices” command and it turned out that my device wasn’t authorized. I had to disable and re-enable USB debugging on my phone and allow USB debugging. It works now! Thanks!

JorensM | 2021-09-13 18:05