How do i reduce the graphics of my godot game. When i export and run it on android, the game lags alot.

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By App_develooer

I want to reduce the garphics of my godot game.When I run it on android, the game lags a lot. Obviously, no one will want to play my game if it is too graphic’s consuming and lags a lot.Only on a few android devices(devices that can run high graphics game) the game runs smoothly.

is your game 3d?

volzhs | 2019-10-10 12:03

You might want to try out to switch the game to GLES2. (Backup your project first).

Although not everything runs on GLES (especially Particles have to replaced by CPUParticles)

If your project is 3D then you can also reduce the numbers of vertices/faces. This is usually done in the 3D editor (Blender i.e. has the decimate modifier for that).

Also shadow filtering, shadow range and the number of light sources can heavily affect performance.

wombatstampede | 2019-10-10 15:58

1 Like
:bust_in_silhouette: Reply From: Calinou

You most likely want to cap the rendering resolution to 1280×720, so that devices with 1080p or 1440p displays don’t waste power rendering graphics at a very high resolution. This can be done by setting the project’s width and height to 1280 and 720 (respectively), then setting the stretch mode to viewport and the stretch aspect to keep.

Also, you can further speed up rendering in 2D-only projects by setting Rendering > Quality > Intended Usage > Framebuffer Allocation to 2D. To apply this change on mobile devices as well, make sure to also set Framebuffer to 2D.

See Multiple resolutions in the documentation for more information.

My project is 3d

App_develooer | 2019-10-11 03:25

Nothing is happening.The results are the same.The game still lags a lot.Please help…
Please answer.I am waiting for your answer…

App_develooer | 2019-10-15 12:16

1 Like