How do I take (DEBUG) off of the title bar.

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By capsaicin

When creating a game the title bar always has the word (DEBUG) after the project name. I am running Godot within Linux. Even when I export the project to Linux and Windows, it still contains the word (DEBUG) after the title name. My latest project is titled Ship Ahoy. The title bar contains the words “Ship Ahoy (DEBUG)”

:bust_in_silhouette: Reply From: Wakatta

When exporting your project after pressing Export Project and you are asked to save a file
Uncheck Export With Debug in your lower left hand corner
Click save and voila you’ve succesfully exported a “release” version of your game
also know that the same can be achieve in the command line like
godot --export "Linux/X11" game_name

Thank you. After reading through varying Q&A posts, I found the answer briefly before your answer. Thank you for your answer.

capsaicin | 2021-01-31 02:46

Thank you very much, I flipping looked everywhere for this.
They need to make a ticket to make this more visible

Darc | 2022-06-03 09:52

1 Like