How do I use the WorldEnvironment correctly?

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By Freya

I am trying to use the WorldEnvironment Node but it seems I am doing something wrong, since no changes are showing up. I thought I would just drop a WorldEnvironment in my scenetree, assign an environment to it and tweak and I did just that but nothing looks different from before. I’m probably making a very basic mistake. if someone could point that out to me, that’d be great! I am using Godot 3.0 by the way. Also this is a 2D game, I hope that is not a problem.

:bust_in_silhouette: Reply From: rolfpancake

Change the background_mode to Canvas and then set adjustments_enabled to true. This can be made in the inspector (Go to BackgroundMode and then to AdjustmentsEnabled).

I only added the WorldEnvironment to the Instancing Demo and changed some settings in the Environment resource and voila:

Scene Instancing with WorldEnvironment

Thanks so much! It works great now!

Freya | 2018-02-06 13:39

No problem, I’m glad I could help.
You can mark the answer as accepted then. :slight_smile:

rolfpancake | 2018-02-06 15:28

Oh Sorry! That was my first question so I didn’t know. I mark it as best know, I hope that’s what you ment

Freya | 2018-02-06 19:32

Yepp, thank you. So everyone of the helping guys here can see that this question is answered.

rolfpancake | 2018-02-06 22:46

Hey, still doesn’t work for me. I tried in a different game and it worked in there. | 2021-04-25 15:03