How do you smoothen graphics in 2d game?

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By NegativeSector

For some reason, the graphics for my game don’t look very smooth.
You will see what I mean from this photo

The photo shows nothing useful to answer this question.
Paste your code instead.

magicalogic | 2021-05-26 04:47

What do you mean “very smooth”? Maybe you’re using the wrong scaling settings?

exuin | 2021-05-26 05:39

I don’t have any code in my project.

NegativeSector | 2021-05-26 14:40

Well then what’s the issue? I don’t really see anything obviously wrong from your image

exuin | 2021-05-26 15:16

Oh. So basically, I loaded some images into Godot and pressed play. All of my images came out pixelated.

NegativeSector | 2021-05-26 15:35

Like in the screenshot you posted? I’m sorry, I don’t really see any pixelation in your images.

exuin | 2021-05-26 16:11

I don’t know why that is. Do you see it in this image?

NegativeSector | 2021-05-26 16:54

Yeah I see it now. Did you resize the images in Godot? Did you resize the window? What are you import settings for the image (import tab is next to the scene tree).

exuin | 2021-05-26 17:29

I didn’t resize the window or resize the images. My import settings are default.

NegativeSector | 2021-05-26 22:09

Okay and the images are not pixelated originally? Can you post the original images?

exuin | 2021-05-26 23:26

:bust_in_silhouette: Reply From: frosty

Do you have a high DPI monitor? (e.g. most Mac displays run at ‘retina’ resolutions) If so, you may need to enable hidpi in your project settings. Go Project > Project Settings > Window > Allow Hidpi.