How i can set the editors zoom sensitivity?

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By Giannis1996

Today i opened godot and the zoom sensitivity was insane in the point that i couldn’t use godot so, how i can set godots zoom sensitivity?

Which scale are you working in? In Godot, 1 unit is generally assumed to be 1 meter. If zoom proves to be too sensitive, you may be working at the wrong scale. To move slowly, use freelook by holding the Right mouse button and use the mouse wheel to adjust the movement speed (or hold Alt while in freelook mode).

Calinou | 2020-03-12 13:55

Yah I think Calinou is right cause when I opened Godot for the first time zoom speed was perfect. Still was when I started using a more sensitive mouse.

Merlin1846 | 2020-03-12 14:31

:bust_in_silhouette: Reply From: jgodfrey

While I’m not sure, you could try some of the zoom-related editor settings.

Editor | Editor Settings...

Search for zoom

Zoom Intertia might be of interest…

Zoom Interia is how fast will the camera behave after you scroll to zoom

small values will make it instant while big numbers will make the camera go to the destination slower

but still zoom interia is not zoom sensitivity

Giannis1996 | 2020-03-12 13:27

:bust_in_silhouette: Reply From: chexmo

This sometimes happens to me… but I suspect its other software fault.
From my point of view, it is more probable to happen when I left godot aside for a few moments while editing arts or while browsing somethig, and when I come to godot again zoom speed became crazy… I close all my programs and start godot again and it gets its default speed again.
I have to say that this is a bit annoying.