How to achieve pixel perfect in godot 3.5

Godot Version



<Hello. I am trying to achieve pixel perfect using Sub-Pixel Accurate Pixel-Sprite Filtering. Although this shader indeed provides pixel perfect rotation on the sprite, yet somehow makes the sprite blurrier than before. I also tried viewport scaling using the 2d stretch mode on the root viewport and a shader on a SubViewport node. However, this did not provide pixel perfect effect. I would appreciate if someone could help me to achieve pixel perfect for my game project. Thanks

My window settings:
size: 640x480
mode: viewport
aspect: keep

Is the filter option turned off under your sprite resource import tab? If it’s on, turn it off and press reimport.

1 Like

the filter option must be turned on in order to apply the material shader.

just updated to 4.2 and problem solved
thanks for the help!

1 Like