How to disable solid collision shape?

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By Pelli

So I have a bomb (kinematic) on the floor, when it explodes,its collision shape becomes larger, to defeat enemys, but the thing is that the collision shape when become larger, hit the ground and goes up, like it pushes it. So how can I disable the solid collision shape without pierce the floor? Because changing the layer or disabling it make the floor and the bomb pierce each other

:bust_in_silhouette: Reply From: Sean

How about you use 2 physics objects?

One for the bomb on a layer/mask which will collide with the floor so it sits in place. Then another which is pinned to it on a layer/mask which doesn’t collide with the floor or the bomb, then “grow” that one out.

so I find out this, if i disable gravity (code below) the bomb don´t goes up, I am adding gravity like this, so don´t understand what is happening

var speed = 500
var gravity = 10000
var velocidad = Vector2()

velocity.y += gravity * delta
var move = velocity * delta

Pelli | 2020-04-23 14:44

I solve it, it was that I didn´t set physic to false, so it´s kept moving, and also I add another physyc objet, thanks works, perfectly now

Pelli | 2020-04-23 17:02