How to exclude objects from occlusion culling

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By stormreaver

I’m using Godot 3.5.2 with occlusion culling. I have an outdoor scene with various parts that need to be culled. However, there is one moving object that I don’t want to be culled. Is there some way to flag it so it’s excluded from the culling process?

:bust_in_silhouette: Reply From: codabase

Hey, you inspired me to author up a solution for you here. Please check this out and let me know if it answers your question!

Thanks for the article, as it does seem to answer the underlying question, but it brings up one more that it doesn’t answer: neither the RoomManager nor the Room have any options for visibility layers, so how do I control which layer the culling occurs on?

stormreaver | 2023-03-22 11:18

It may be based on the layers of visibility beneath, perhaps this GitHub issue here that was closed can be useful?
Portal occlusion culling [3.4] by lawnjelly · Pull Request #46130 · godotengine/godot · GitHub

codabase | 2023-03-22 14:50