How to fix FileSystem stuck at "Scanning Files, Please Wait.."?

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By Dinosaur
:warning: Old Version Published before Godot 3 was released.

Windows 7 x64
Godot Engine v2.0.3.stable.official

This problem started after I moved and renamed some files (scripts, images, scenes, sounds) in a project’s resources folder for testing purposes.

After finishing testing, I made my best effort to restore their names back to the way they were before, but I may have failed, and now Godot’s FileSystem panel is stuck at “Scanning Files, Please Wait…”

Scanning Files, Please Wait..

The console/cmd window is meanwhile being spammed with “ERR OUT OF MEMORY” error messages as shown in the following screenshot.

Error log

Reopening the project does not help. I have also tried rebooting my computer.

Is there any way I can troubleshoot this issue, such as finding out which filenames Godot may be failing to find in the project’s resources folder (assuming that is the cause of the problem)?

Thanks in advance for any input on this issue!

I’m not sure but try deleting folders under C:\Users\[username]\AppData\Roaming\Godot\config

volzhs | 2016-06-07 01:46

Thanks for the suggestion! I tried, but I don’t have a config folder in that path; only C:\Users\[username]\AppData\Roaming\Godot\app_userdata\, containing (mostly empty) subfolders, one for each project.

Removing the entire app_userdata folder did not seem to have any effect on the issue.

I did find a config folder; \Steam\steamapps\common\Godot Engine\editor_data\config\, but removing its contents didn’t seem to help either.

Dinosaur | 2016-06-07 12:28

Try to delete .fscache or meta/flags files? (do a backup before)

Zylann | 2016-06-07 12:38

Thanks for the suggestion. I can find some .fscache files in a couple of the demo project folders, but nowhere else. I’m also not sure where to find the meta/flags files.

Sorry, I neglected to mention; I’m running on Windows, if that makes any difference.

Dinosaur | 2016-06-07 13:00

it’s probably fixed recently on github master.

volzhs | 2016-06-28 18:10

I’m using the Steam version, which is now updated to v2.1.stable.official.

The issue still persists.

Dinosaur | 2016-10-10 20:17

:bust_in_silhouette: Reply From: ulty

I had a similar problem using the build in move method for .scn files.

I had some problems using the build in move method for .scn files. Moving them did work and the dependencies did update. But after I was done, opening the project slowed down with the text “scanning files please wait” appearing. I did not find anything wrong in my .tscn files so I started replacing my .scn files with .tscn files which fixed the problem.

Thanks for the info!

If you don’t mind, do you know if there’s any way for me to start replacing my .scn files with .tscn files at this stage (I haven’t made any progress on this issue yet)? All I know is that .scn files are in a binary format, whereas .tscn files are in a human-readable text format. Thanks!

Dinosaur | 2017-10-11 14:19