How to fix particle delay when starting

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By Noccai

So when you instantiate or activate a particle node, there is a short delay before it actually starts emitting and while not too long it is long enough to completely mess with the way it feels.

Is there any way to fix this, all I found was something vague about shaders, but that was basically allways associated with lag spikes, which I do not have.

Maybe it is something in the settings, but I never got acceptable result no matter how much I changed them, so yeah, please help me. Thanks.

:bust_in_silhouette: Reply From: Inces

There is a property in particle node, outside of particle material, called preprocess
It uses float argument to simulate the state of emission after given time. Which is exactly what You need.

So I was just being a noob, nice. Thanks you very much!

Noccai | 2022-09-18 10:40