How to import really big objects (planets) in godot (Maximum viewport size)?

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By Tachekentya

Hi. I want to import a huge object from blender (planets) the problem is that when I import it to Godot the obj is to big. Even after changing the “view Z-Far” in the “viewport settings” to the maximum (10000), I cannot see the object. I could scale the obj in blender to a more accessible size, but that will force to scale all the other small objects in the same proportion. How can I change the maximum value of “View Z-Far” to more than 10000? I don’t know if this will be the best approach. Can you think in a better solution to this tipe of problems?

are you sure that´s not an issue with the camera node and its far property?

Andrea | 2018-07-06 07:38

I can’t see the geometries even in the 3dview, but when I scale them everything works well. Scaling in blender is working as a good solution for now. I think the maximun size for geometries in godot is about 35000km (if you change the “view Z-Far” in the “viewport settings” to the maximum (10000)) or that is what I found with try and error with geometries from blender.

Tachekentya | 2018-07-07 12:42