How to increase or remove fps cap?

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By MathiasStrohkirch

I am running on a 144 fps display but am only getting a max fps of 30 (even with godot’s pre-made games). I have tried setting Force Fps in the project settings to 0 and to a number larger than 30, but either way I get 30 fps. It is like this when running the game in the godot editor and after export. How can I increase or remove the fps cap of 30? (for a 2D game)

:bust_in_silhouette: Reply From: Poobslag

For 3D games, I know this can be toggled in the Project Settings, under Display → Window → Use Vsync. Disabling VSync skyrockets my FPS from 60 to ~2,500. It may be the same for 2D.

I have done as you mentioned.

Fresherslive | 2021-02-21 18:39

:bust_in_silhouette: Reply From: daniklad

If you are getting 30 fps locked on a 144 Hz display that could be a problem with your
display cable.

First of all, it should be a HDMI or DisplayPort cable, not a VGA-cable.

If you get more than 30 fps in other games and apps then it is not a cable problem obviously.