How to install export templates in Godot 2.1.4 on an iMac.

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By nu2godot
:warning: Old Version Published before Godot 3 was released.

On an Intel iMac running OSX, El Capitan and unable to install the export templates.
Downloaded .tpz to desktop. Followed procedure for installing. However…
Godot 2.1.4 Stable won’t open and install. No native app on Mac will open .tpz.
Documentation does not offer solution. New to Godot and game making in general.
Help would be greatly appreciated!

:bust_in_silhouette: Reply From: jospic

For Godot 2.1.4, go to editor settings (on top right) and select “Install export templates”.

Thank you for answering.
I did that originally. Downloaded the file, opened Godot. clicked once on the .tpz, to highlight it, then clicked on “install export templates” and clicked on “open” and waited for some reaction but nothing happened.
At that point I double clicked the .tpz and that launched a pop-up stating that Godot could not open the file. Must be something I’m missing?
Thanks again!

nu2godot | 2018-01-16 21:49

  1. Are you sure have downloaded compatibles templates with your Godot version (2.1.4) from here?

  1. The correct way is:
    2.1) Download templates (file .tpz)
    2.2) Click on “Settings->Install Export Templates” (in your Godot editor)
    2.3) Navigate in your download directory and highlight .tpz file, then click on “Open”
    2.4) Click on “Export” button (on top left) and check on “Project Export Settings” dialog if all is ok


jospic | 2018-01-17 08:26

I have downloaded “Godot_v2.1.4-stable_export_templates.tpz” to my Desktop, opened Godot 2.1.4, clicked on “Settings”, clicked on the “Install Export Templates” drop down which opens the “Open A File” window in the Godot interface. I’ve then clicked on the “Godot_v2.1.4-stable_export_templates.tpz” on my Desktop once to highlight it, returned to the Godot “Open A File” window and clicked on the “Open” button that sits below and to the right of the “Filter” bar that contains “Template Package (*.tpz)”. The button then displays an outline border color as if locked in the clicked state. I have waited a bit and then clicked on the “Export” button and then clicked on each of the export options and each one returns: “No Export Templates Found.” Maybe you can see something in this that I am doing wrong. I have gone so far as to paste the path to the .tpz file on the desktop into the “Path” bar at the top of the “Open A File” window and clicked open. Same result. Nothing. I have done this 5 different times and trashed each download afterward in case any were corrupted before starting again.
I appreciate the time you’ve spent on this!

nu2godot | 2018-01-17 22:06

You could also try to install the export templates manually:

  1. Rename .tpz file in .zip
  2. Extract this .zip file in a temporary folder
  3. Copy alla extracted contents in your home hidden folder /home/YourUsername/.godot/templates
  4. Restart Godot editor and check Exported dialog status


jospic | 2018-01-18 08:23

I absolutely appreciate the effort you have put into trying to help me solve this issue.
I don’t quite understand your last set of instructions with regard to “home hidden folder”. I did extract the files but was unable to locate the “.godot/templates” to copy them to.
As a last resort, I dragged the and .tpz files to the trash and deleted both.
I downloaded both again, to start fresh, and tried the original method once more.
It still did not work and I am too frustrated to continue with it.
I like the program but I have again removed everything Godot from my computer.
I have spent a lot of time with the Adobe CS4 and CS5.5 Creative Suites (Flash, Photoshop, Dreamweaver, Illustrator, etc.) so I have been spoiled by their built-in functionality. I maintained a personal portfolio website for 5 years up until 2015.
I’ve only recently delved into open source apps since the Apple OSX update, that I foolishly downloaded without researching compatibility first, has rendered my version of the Adobe Suite unusable (with the exception of Photoshop). I have no interest in renting their software. I am back to square one now with open source apps like Blender, GravitDesigner, Atom and FileZilla replacing the Adobe Suite apps.
Godot looked like a viable 2D replacement for Flash. I will check the site for future stable updates and if the developers have found a way to incorporate the export templates within the app, I will certainly download it.
Anyway, You have been very kind and patient and I sincerely thank you for your efforts!

nu2godot | 2018-01-18 16:58