How to make an AudioStreamPlayer2D looping?

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By Syl


Tried all the loop mode, none is doin a loop…

1 Like
:bust_in_silhouette: Reply From: jgodfrey

What format is the stream you’re trying to play (WAV, OGG, …)?

If it’s a WAV file…

  • Select the asset in the FileSystem tree
  • Select the Import tab (beside the Scene tab)
  • Select the Loop checkbox
  • Click Reimport

Now, playing the stream should cause it to loop.

If it’s an OGG file, you can simply set the Loop property of the AudioStream2D player to loop the stream.


Syl | 2020-02-19 00:05

That didn’t work for me, I don’t see any import tab…

boston2029 | 2022-07-07 21:14

It should be right beside the standard Scene tab, as shown below:

jgodfrey | 2022-07-07 23:03

Thank you so much for this tip!

BooBigal | 2023-03-31 12:40

1 Like