How to mono? "just install sdk" not enough?

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By grumblygibson

Long-time gdscript user, unity user, trying mono godot for the first time.
I’ve tried to read the docs and google search this, but I’m stuck on something ostensibly basic.

downloaded Godot 4.0.3 stable mono windows (Windows 10 fully updated).
Installed dotnet 7.0 sdk
run new empty project in godot (F5) works okay.
Add basic cs script with empty _ready(), and change nothing.
Trying to run the project (F5) and I get this:

C:\Program Files\dotnet\sdk\7.0.302\NuGet.targets(156,5): Field not found:     'System.Func`2.Item2'."


       "C:\Users\<user>\projects\testproj\testproj.csproj" (Restore target) (1) ->
       (Restore target) -> 
         C:\Program Files\dotnet\sdk\7.0.302\NuGet.targets(156,5): error : Field not found: 
'System.Func`2.Item2'. [C:\Users\<user>\projects\testproj\testproj.csproj]

I’ve tried deleting and recreating my nuget.config file.
I can create and run projects and add packages on the command line, but only if I --disable-restore --force, as restoring causes errors for some reason.

:bust_in_silhouette: Reply From: grumblygibson

Godot does not work with .net SDK 7.0
Uninstall 7.0, install 6.0. Problem solved.