How to set mipmap filters for loaded texture?

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By thany

The scenario is, I’m trying to load a texture to simply show it on a 2D scene and doing some transformation on it.
The problem is when I scale down the node (I’ve tested it with TextureRect and Sprite) the texture has some edgy artifacts (like it does render it with highest resolution) and the loaded texture does not have any setting for mipmap filtering.

:bust_in_silhouette: Reply From: p7f

For enabling mipmap generation, select the image file in the file system dock, the go to the import dock, check mipmap option, and then press reimport.