How to solve "Output overflow, print less text"

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By Not_a_Robot
:warning: Old Version Published before Godot 3 was released.

Hello everyone!

I need to debug my application and the editor’s console, in the output tab, after some text says:

[output overflow, print less text!]

How can I print every thing I want, please?

It is necessary to print all that text.

Thank you very much in advance!

:bust_in_silhouette: Reply From: volzhs

Try to increase value of max_remote_stdout_chars_per_second at Project Settings > Debug.

Hi Volzhs!

Thank you for your answer.
I already checked that option, but it seems it is for remote stdout, not local.

After asking on IRC, punto told me that in GNU/Linux, you can execute the editor from the console and, therefore, all output is printed there.

I will use that as a solution for the moment since I can check all what I need, although it is not what I would like.

Thanks again for your time, Volzhs! :slight_smile:

Not_a_Robot | 2016-09-27 07:31