How to stop ScrollContainer from not activating Scrollbar and resizing contents to fit in the box

This picture shows that you have the ScrollContainer LayoutMode set to Anchors and additionally the Anchors set to Custom.
Click the RESET swirl on LayoutMode and return it to Position.

Yea I know, but when I set those green drop bar things so that it stays full screen when the window is, it’s set back to anchors

Yes, you should still be getting the scroll bars.
I’m stumped

let me try again and see, might have to even show you a video to demonstrate

Video: https://drive.google.com/file/d/1RsSLJwUjbyCRjfyLfkoO-FX2D2EBiq8S/view?usp=drive_link

I cant look at video but I get whats happening.
I just don’t know why.
I recommend starting from scratch with a new scene.
Don’t change any of the default settings of the controls except for the ColorRect which needs a custom min size.

I have given you permission to view the video by downloading it.

Also how do I set the ColorRect’s custom minimum size?

Also, the video is viewable now

ColorRect minimum size is under Layout/Custom Minimum Size

1 Like

Alright, I’ll check it and see if it works.

You can see the video with the Google drive link now, just check it so that you can see exactly what my problem is

I just checked, and it actually worked.

All I had to do was change the Custom Minimum Size, and now the scroll bar actually shows and the contents clip now

Either that or as soon as I changed it just started working for some reason.

THANK YOU VERY MUCH, this has been pestering me for a good while now and I’m happy it’s finally resolved. I’ll probably look into more detail to see what the problem actually was. But either way, Thanks :gdparty: :smiley: