HTML Black Screen

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By BuilderPro715

Every time I export a project in the .html format and load the file it gives me a black screen and nothing else. I have tried many solutions but I can get it to be normal.

:bust_in_silhouette: Reply From: RuKeN

Have you tried to open it with a different browser?

When working with web imports is important to have the most common browser installed like Google Chrome, Mozilla Firefox and Opera

Also check that you have JavaScript enabled in them and, the most uncommon could be that, if you are using Windows N version, those build of windows does not have the media features so installing/activating them could solve the issue

I have checked multiple browsers and that doesn’t seem to be the problem. I am also using Mac. But how do I know if I have JavaScript enabled?

BuilderPro715 | 2022-08-22 22:33

:bust_in_silhouette: Reply From: trisolaran

Some suggestions from my experience with html-export:

  • check, if it works in the engine (export → runnable → click the html5 icon in the engine)
  • start a python html server and start from there
  • black screen is often a bug in code, open developer console in the browser and check for possible errors (developer console really helps alot, i could find all my export-related errors there)
  • some browsers / older oses cannot open webassembly (wasm)
  • try with a minimal godot project and test with it
  • enet doesnt work in browser
  • check the docu for restrictions of web-export
  • when uploading files to a server, check if all files are uploaded and in the right place
  • in export-resource-tab, give a list of your non-resource files-extensions
  • check, how you load files (res or from somewhere else)

maybe i forgot something, but this is my recollection, what could happen with html-exports.

:bust_in_silhouette: Reply From: BuilderPro715

After looking in the developer console I found I have two errors. But I can’t figure out how to fix them: Uncaught ReferenceError: Engine is not defined. and; Failed to load resource: the server responded with a stasis of 404 (). After hours of searching I can’t find an answer.