I can't define a class unless I delete and redownload the Godot.exe. Why?

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By thriller1234519

I’ve been beating my head against a wall because I couldn’t do something as simple as label a class using class-name. The text following class-name would be greyed out no matter what I did.

Out of desperation, I deleted the Godot=v3.5.1-stable=win64.exe file completely, and redownloaded it. Suddenly, all the custom class labels I made before worked!

But…when I tried to make a NEW custom class label, it would be greyed out again. The ones I made BEFORE I deleted and redownloaded the .exe file worked fine.

So, I tested it. I wrote another new class_name in a random script, and then deleted the .exe file again. I kept the zipped file and just re-extracted the .exe from it and ran it.

Low and behold, the new NEW class_name was suddenly valid!

Does anyone have any idea what the heck is going on?
I’d really rather not have to re-extract the .exe every time I want to change/create a class. XD

:bust_in_silhouette: Reply From: Lopy

I believe that the issue was solved from restarting the Engine, and not changing its file. When you make a new class_name, the name is not colored properly until you reopen the project. This is visual and should not cause any issue in code.

To update the color, you can either restart the Engine, or click on “Project/Reload current project”.

This is likely fixed in 4.0, but I haven’t checked.