I followed a tutorial but i failed and i don't know why...

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By Giannis1996

I followed a tutorial but i failed and i don’t know why, maybe it’s because i didn’t understand the connections

the tutorial series is here: https://www.youtube.com/playlist?list=PLpj8TZGNIBNxe-Sba4mohPSXOxoyicLYs

and the video that i “lost the game” is https://www.youtube.com/watch?v=ISyAFcoZtbA

from part 0 to 9 everything seems to work 100% fine but at part 10 the enemies are still not shooting me and i don’t know why

my try on this tutorial is here: test
So, what have gone wrong?

:bust_in_silhouette: Reply From: millighost

From looking at your project, it seems the enemy fires when the timer runs out, but in the Timer-node’s properties it is not started. Setting it to autostart makes it fire after 1 second.

:bust_in_silhouette: Reply From: brazmogu

I didn’t watch the video all the way through, so I don’t know if the video forgot to mention it or you overlooked it… but simply you need to start your timer!

You can do that by either starting it in the code (in _ready, I suppose) or set the Autostart property of the timer to true so it’ll automatically start counting.

:bust_in_silhouette: Reply From: Giannis1996

ok guys i found it, i should check the Autostart checkbox at enemy>Timer
now that i check it the enemies are shooting fine!
The problem is solved!