Icky 3D navigation in Godot

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By Inces

Has anyone else this problem ?

Sometimes when navigating in 3d scene in editor, meaning zooming in and out, scrolling and moving with middle mouse button, something happens and navigation becomes stiff, unable to zoom in properly, changing pivot of movement around viewed scene so turning one direction becomes very slow and so on. I never had any of these problems in Blender, where navigation is perfect.

Does anybody know what is the cause of this editor camera behaviour and how can I counteract it ?

:bust_in_silhouette: Reply From: Calinou

If the 3D camera pivot changed, it’s likely because you panned the 3D view by holding Shift and moving the mouse with the middle mouse button pressed, or you enabled freelook mode by holding down the right mouse button.

You can select a node and press F to set the 3D rotation pivot around its origin. In 3.4, this also works when you have nothing selected (in which case the 3D rotation pivot will be placed at the scene’s origin).

having the exact same issue, dont know what caused it, everything was working fine now my movement in the editor is very slow cant zoom, cant move properly it is very slow to move around, i dont know how to solve it.

Which Godot version are you using? Did you change camera near/far distance settings in the View menu? Did you try resetting the camera pivot as described above?