I'm not sure if I understand Android Export. APK is generated, but not working.

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By lucasfazzi

So; I read the documentation to generate an APK and I followed step by step; worked really well, I was able to create a functional debug APK; I tested it on my phone and in a online emulator and everything worked perfectly.

And then the problems started …

I deleted the app from my phone and did the proper cleaning; I generated a new version but not as an update, rather a new app and could not install. I thought it might be some residual file conflict between the old version and the new one, but I went to test in the online emulator and it also did not work; the curious thing is that in online emulator it warns that “the app is unsigned”, even though I did not receive any error messages when generating the debug APK on Godot and also I marked the “signed” box.

I thought it might be a problem in debug.keystore and I tried to create another, but no matter how much modification the problem persists. After this, no more apps were successfully generated, even new ones, and all others persist in the online emulator giving the message “the app is unsigned”.

So I tried to reinstall the first version of the app … and it worked perfectly again.
I think it’s a problem generating debug.keystore, some data conflict, but I’m not sure how to deal with, even if I understand it.

Working on Godot 3.1 GLES 2 x86.

NEWS (great or not so great):

I made a new project with nothing (just a Node2D) and make a APK file: it worked on my phone and in the online emulator.

I think it could be a corrupt file or something that is craping some versions of exporting APK file.

lucasfazzi | 2019-04-04 02:22

Does your project contain files with non-ascii file names? (Like “hèlp.scn”, or “fähler.png”). Maybe the signing tool has problems with these files which probably is also noted somewhere in the lengthy output when packaging the apk.

And to make this certain:

It fails to install (so the app icon is never visible in the apps list)?

It does not fail to run the app (it does not get that far)?

wombatstampede | 2019-04-04 10:21

:bust_in_silhouette: Reply From: lucasfazzi

yep, that’s it. you are right.

holly mother I was devasted trying to figure out what I’m doing wrong and it’s all about a miserable non-ASCII Character in a png file.

now, everything is working great again.


I still have some problems with the update. but at least if I generate a “new” app (just changing the unique name and name), the app works on both the mobile and the online emulator.

lucasfazzi | 2019-04-04 18:32