Impossible to limit frames, neither with v-sync, nor with max fps, in Godot 4.0

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By Snark Bucham

Hello, I don’t know if it is a bug, or something that I am not able to see. Godot 4.0 does not limit the frames, neither by activating v-sync nor max fps. I have tried it in all versions and none does it in my case. Unlike the 3.x versions that do limit them correctly. I have tried managing the nvidia settings and it does limit or not limit the fps in all other programs, but not in Godot 4.0. Godot 4.0, in my case, does not limit the fps with any of the commented options.
Windows 11.CPU AMD Rizen 9 5950 ,GPU Nvidia RTX 3060 , 32g RAM. Does anyone recognize my problem? Greetings and thank you.

:bust_in_silhouette: Reply From: JustADeer

what version of godot 4 are you using? im using godot 4 beta 10 and Engine.max_fps and vsync works.

Hello, thanks for your interest, I already managed to solve the problem. I don’t remember exactly which one it was. But basically it was that there are two ways to see the fps in godot, and one of them does not give you the fps of the game but of the editor or something like that.
When I verified that I was limiting them correctly, I did not use those options again and I no longer remember them.
The good way I think I remember was with the project option in debug. print fps. And the bad one was the one I used at first because I found it before and I didn’t know that it didn’t measure fps correctly I don’t remember it anymore (if you know what I’m talking about, it wouldn’t hurt either, if you refresh the problem to remind me of the two options). Thanks again for your interest and greetings.

Snark Bucham | 2022-12-29 15:11