Input lag in Godot UI

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By major9th

First time user of Godot, i opened the program for the first time and it has an input delay which is very visible in naming a new project but happens everywhere in the program: if i type an F and then an A, the F only appears after i typed the A, and the A only appears if i type another letter and so on…
Any help appreciated.
(this also happens with clicking buttons and everything else)

This is a known issue, try upgrading your graphics driver to the latest version provided by Intel. Alternatively, you can start the Godot editor with the --verbose command-line argument to work around the issue.

Calinou | 2020-04-24 07:11

:bust_in_silhouette: Reply From: Donni

Having the same issues. I noticed when you boot with --verbose it solves the issues but only for SSGLES2. Are you also running with Intel HD graphic card?

Update: Found a solution! Enabling the Update Spinner solves the issues.
This can be done in Editor → Editor Settings → Interface → Editor → Show Update Spinner.