Instanced scene not getting complete tree

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By SpaGa

I have this instanced scene in my main scene, but when i try to get te root node of the main scene through a script that’s attached to the instanced scene it returns the root of the instanced scene instead of the actual root. Why is this?

PS: I’ve tried every sensible method of getting the root

Example tree (actual):

  • cube
  • light
  • player (instanced scene) with script
  • |- Meshinstance or smth
  • |- Camera or smth

the tree the script returns:

  • player
  • | - Meshinstance or smth
  • | - Camera or smth
:bust_in_silhouette: Reply From: exuin

Have you tried get_tree().get_root()?

Yup. I’ve tried all of those methods.

SpaGa | 2021-03-31 07:04

That’s strange. You are using 3.2.3 right?

exuin | 2021-03-31 07:11

I think so. I’ve just installed the newest version not long ago.
Edit: Just checked, i do indeed have 3.2.3

SpaGa | 2021-03-31 08:59