Ipad pro 11 wont use full screen tried everything

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By made10223

I’m trying to test out my game on my iPad Pro 11 but the screen isn’t the full screen and I have tried tons of different things and can’t figure it out. It’s on both the sim and the actual device.


:bust_in_silhouette: Reply From: pip

Godot is still using the UILaunchimages in the exported project which are deprecated. You have to use a launch storyboard. Your game should launch in fullscreen mode after that.

Xcode → File → New File → Launch Screen

Still getting black bars vertically and horizontally. Is there any settings that have to be set for this to work?

jtarallo | 2020-06-15 23:40

:bust_in_silhouette: Reply From: idchlife

Now Godot (3.4.2) has option when exporting: User Launch Screen Storyboard.

Use it and app/game will be fullscreen.