Is it possible to have a normal mapped sprite cast shadows?

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By jarlowrey
:warning: Old Version Published before Godot 3 was released.

When I overlay a LightOccluder2D on my sprite it prevents any light from entering the object and interacting with the normal map. Sprite and light have blend modes of “Mix” occluder has “Add”, but I’ve tried different variations with all of them.

normal mapped shadow caster

:bust_in_silhouette: Reply From: jarlowrey

Setting “Cull mode” to “Clockwise” in the OccluderPolygon2D fixed this issue