is there a way to prevent mesh from casting shadows in shader ??

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By Inces

I already know geometry_instance provides method to prevent casting shadows. Unfortunately icky GridMap node with its MeshLibrary resource in Godot 3.2 only transfer properties from bodies, shapes, mesh and materials into GridMap items. Setting enableshadow in mesh_instance converted to .mesh or meshlibrary does nothing. I just want to have one GridMap item wall that does not obscure visibility, while is not transparent. I was hoping there is something in light() function of shaders to inhibit casting shadow or redirect incoming light ??

Were you able to find out a solution? I am have the same issue.

LGS | 2023-01-07 04:22

I stopped using this trash GridMap, now I make custom 3d tilemaps using MultimeshInstances

Inces | 2023-01-07 04:40