Issue with building in Mono.

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By FrostLace

When I try to build a basic game from a tutorial, there is an error, "C:\Program Files\Mono\lib\mono\msbuild\15.0\bin\Microsoft.Common.CurrentVersion.targets(2101,5): error MSB3248: Parameter “SearchPaths” has invalid value “C:\Users\User\Desktop\Godot\Tutorials\Basic Game.mono\assemblies\Debug\ .winmd”. Illegal characters in path. [C:\Users\Ian\Desktop\Godot\Tutorials\Basic Game\Basic_Game.csproj]
Does anyone know how to fix this?
It doesn’t seem like anyone else has this issue, so maybe I am just not doing something correctly. I have tried to reinstall mono, that doesn’t help anything.
Sorry if this is a dumb question.

:bust_in_silhouette: Reply From: joao620

Running the editor with Mono support requires Mono 5.2 or greater to be installed on your system. On Windows you will also need MSBuild 15.0, which is bundled with Visual Studio 2017 but can be installed separately with Build Tools for Visual Studio 2017.

I was having the same problem, I only had the Mono installed, sometimes it worked and sometimes it gave an error. To solve it I installed the Build Tools for Visual Studio 2017 without selecting any item on the left, just clicking the install button on the right

:bust_in_silhouette: Reply From: Clonck

Heya, I don’t know if you’re still stuck on this problem, but after bashing my head at the screen for about 2 hours trying to solve this issue on my computer, I found out that the problem for me was that my editor settings → Builds-> Build tools for some bizzare reason switched from MSBuild (VS Build Tools) to MSBuild (Mono).

So try Editor Settings → Builds → BuildTool and setting it to MSBuild (VS Build Tools)

PS: I accidentally commented it instead of answering so there’s 2 of this message. Sorry.

:bust_in_silhouette: Reply From: ladiagonaledupoulpe

For us, setting it to MSBuild (VS Build Tools) failed, we got this error :

“C:\Users\felic\Documents\GitHub\ladiagonaledupoulpe-game-two\game-two\game-two.sln” (Build cible) (1) →
“C:\Users\felic\Documents\GitHub\ladiagonaledupoulpe-game-two\game-two\game-two.csproj” (cible par défaut) (2) →
(CoreCompile cible) →
C:\Users\felic\AppData\Local\Temp.NETFramework,Version=v4.7.AssemblyAttributes.cs(4,12): error CS0579: Attribut ‘global::System.Runtime.Versioning.TargetFrameworkAttribute’ en double [C:\Users\felic\Documents\GitHub\ladiagonaledupoul

And when we set to MsBuild (Mono), it builds, but when we export, we got the error you get at the top of this page.