Keep on getting get_node: (Note not found "..." (releative to "...").) even though the node is there

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By SpicoTheMirrorSpirit

Whenever i run the game in its current state i keep on getting the same error

Heres the Scene Tree:

  • Master
  • Button
  • Score

and heres what i wrote in the script i assigned to Master

extends Node

var clicks = 10

func _process(delta):
     $Score.text = "Clicks:" 

I keep on getting this error whenever i try to run the game:

get_node: (Node not found "Score" (releative to "/root/Master").) 

I looked into alot of places for the past 30 minutes trying to fix this, this is my first project outside of the tutorial projects, it has something to do with its path but i cant figure out where it is for the life of me
Thanks in advance!

Works for me. I assume Score is a Label?

extends Node

var clicks = 10

func _process(delta):
	$Score.text = "Clicks:" 


--- Debugging process started ---
Godot Engine v3.3.2.stable.official -
OpenGL ES 3.0 Renderer: NVIDIA GeForce GT 650M OpenGL Engine
OpenGL ES Batching: ON

wyattb | 2021-06-21 21:52

Is Score ever removed from the game? You’re getting it every frame.

exuin | 2021-06-22 00:10