Light2D Item cull mask not working, excluded items are still affected by the Light2D that is on a different layer.

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By MadJester

Hello there,

So i have a ‘night’ level in which I’ve added a light2D node with Mode Sub to make the level dark. Its Item Cull Mask is set to Layer 1.

Now I instanced my player scene into the level the players’ Light Mask set to no Layer.

Expected behaviour: Player not affected by the level’s Light2D, alas everything in the scene is black including the player who is on a different Light mask.

Can anyone point out where I go wrong? Or how I exclude my player from being affected by the Levels’ Light2D?

What I tried:

  • set the players’ Light Mask to a different layer. set the players’
  • Material to New CanvasItemMaterial with Light Mode Unshaded. set the
  • players’ node below or above the Light2D Node.

Level Hierarchy :

Player Light mask setting
Light mask
Light2D settings:

:bust_in_silhouette: Reply From: MadJester

Alright I found a fix. I simply set up my lighting in my level and the re-instanced my player scene. That seems to fix the issue. maybe it’s a bug.