Loading scene not working after exporting project, but working inside Godot

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By CrazyGamesMC

I am using Godot 3.2 on Windows using Mono.

Whenever I try to do GD.Load("res://scenes//ui//Pause.tscn") or something like that, I get the following error:

ERROR: Cannot open file 'res://scenes//ui//Pause.tscn'.
   At: scene/resources/resource_format_text.cpp:1228
ERROR: Failed loading resource: res://scenes//ui//Pause.tscn.
   At: core/io/resource_loader.cpp:278
ERROR: Error loading resource: 'res://scenes//ui//Pause.tscn'.
   At: core/bind/core_bind.cpp:76

And that happens with whatever scene I try to load. I even exported it to a zip file to check whether all the files are being exported. And yes, all the files seem to be exported. The .exe or .apk also seem to have areasonable file size. I also checked for casing, but that’s not an issue as well.

I tried to export both to Android and Windows, but neither of them worked.
This issue started to appear just recently as I was still able to export my project yesterday.

I would really apreciate any suggestions. Thanks in advance! :slight_smile:

I have the same issue.

msdogra | 2020-07-30 17:35

:bust_in_silhouette: Reply From: cgeadas

You are using the path “res://scenes//ui//Pause.tscn”.
I don’t know if, with Mono, Godot uses different path conventions but try using “res://scenes/ui/Pause.tscn”.

:bust_in_silhouette: Reply From: msdogra

In my case, I found that the scenes / sprites were not included in the project. I had to open the solution in Visual studio and include all the required folders/resources in the project, after that export started working much better (except for the steam dlls)