Loop setting of animation is reset after restart of Godot

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By BR14Nx

I imported my .glb character into Godot and activated that little loop icon for some animations in the top right of the animation window.
If I restart Godot this setting will be reset, so no longer any loop. I guess it uses the .glb standard setting for the animation.
I can save the animation and load it again, but that’s as handy as just activating all the loops again.

How can the loops be saved and loaded upon restart?
(And no, I don’t want to make that setting in the .glb)

:bust_in_silhouette: Reply From: Gluon

You can use


in the ready function which will set the loop to either false or true depending on what you want. Not sure why it would be resetting but if you put the above in your ready function it should set loop to true each time you start a scene up.

Thanks for that hint. That works.
So normally the reset is not intended?

BR14Nx | 2023-02-13 22:10

No I cannot say I have ever heard of an animation resetting its loop to false/true when the godot engine is closed down before. Thats a new one on me and I dont know how that would be happening unless you didnt save the scene after changing the loop to true? But in any case the above should be a work around for the issue.

Gluon | 2023-02-13 22:13

I checked several times to save the scene after I set the loops. But yeah…it resets every time after a restart.

BR14Nx | 2023-02-14 12:42