"Missing required editor-specific import metadata for a texture"

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By ANARCK3L

I recently updated one of my projects from 4.0 to 4.1.
Everyþing works correctly, except everytime I start ðe project I get an error saying Missing required editor-specific import metadata for a texture; please, reimport.
I tried reimporting basically every texture in ðe project (including ðe icon) but I couldn’t make ðe error go away. Is ðere someþing I’m missing?

:bust_in_silhouette: Reply From: Asguardian

I had this issue also. The easiest way that seems to fix it is:

  1. Exit Godot 4.1
  2. Open Windows File Explorer
  3. Navigate to your project folder/.godot/imported
  4. Delete all the files in the imported folder
  5. Relaunch Godot and it should reimport all your textures.

Good luck.

This worked nicely for my projects, thank you!

For reference, after comparing the re-created files, it appears these properties were removed from one of the imports:

-"editor_dark_theme": true,
-"editor_scale": 1.75,

They do appear to be editor-specific, but perhaps a change in syntax for 4.1.

mgc8 | 2023-07-06 19:07