Missing shared libraries for native scripts when exporting to Android using custom build

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By hippodamos

When I try to export a project which uses gdnative and compiled libraries to android platform, using custom build option, the compiled libraries (.so files) are missing from the .apk package. If I don’t use the custom build option the library files injected into package correctly. Is there a way to include shared libraries into custom built .apk packages?

When explorting the game, did you specify the exact library files in the export dialog (I think the place to specify then is under the “Resources” tab in the export dialog)?

Ertain | 2021-08-10 09:05

I tried that but the files specified in the resources tab goes to “assets” folder. However app looks in “lib” folder for linking the shared libraries and thus cannot find and link the shared libraries.

hippodamos | 2021-08-10 12:49

:bust_in_silhouette: Reply From: sanjodev

I ran into this problem as well and had to figure out the solution. I replied with an answer in this other thread.